$re = '/^[^\s@.]{0,25}[0-9]{3}@gmail\.com$/m';
$str = 'john.doe123@gmail.com
doe123@gmail.com
test12@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);