re = /^[^\s@.]{0,25}[0-9]{3}@gmail\.com$/m
str = 'john.doe123@gmail.com
doe123@gmail.com
test12@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end