const regex = /^[^\s@.]{0,25}[0-9]{3}@gmail\.com$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s@.]{0,25}[0-9]{3}@gmail\\.com$', 'gm')
const str = `john.doe123@gmail.com
doe123@gmail.com
test12@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}