#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=.*\d)(?=.*[A-Z])(?=.*[a-z])[A-Za-z\d]{8}\b"
Local $sString = "What SHOULD match:" & @CRLF & _
"Passw8rd" & @CRLF & _
"on1oN!91" & @CRLF & _
"Yb9udbsk" & @CRLF & _
"" & @CRLF & _
"I am getting matches in regex101 for the following strings that I do NOT WANT to match:" & @CRLF & _
"" & @CRLF & _
"88888888" & @CRLF & _
"869guifr" & @CRLF & _
"Password" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")