$re = '/\b(?=.*\d)(?=.*[A-Z])(?=.*[a-z])[A-Za-z\d]{8}\b/m';
$str = 'What SHOULD match:
Passw8rd
on1oN!91
Yb9udbsk
I am getting matches in regex101 for the following strings that I do NOT WANT to match:
88888888
869guifr
Password
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);