const regex = /\b(?=.*\d)(?=.*[A-Z])(?=.*[a-z])[A-Za-z\d]{8}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=.*\\d)(?=.*[A-Z])(?=.*[a-z])[A-Za-z\\d]{8}\\b', 'gm')
const str = `What SHOULD match:
Passw8rd
on1oN!91
Yb9udbsk
I am getting matches in regex101 for the following strings that I do NOT WANT to match:
88888888
869guifr
Password
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}