use strict;
my $str = 'What SHOULD match:
Passw8rd
on1oN!91
Yb9udbsk
I am getting matches in regex101 for the following strings that I do NOT WANT to match:
88888888
869guifr
Password
';
my $regex = qr/\b(?=.*\d)(?=.*[A-Z])(?=.*[a-z])[A-Za-z\d]{8}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}