const regex = new RegExp('(?si)(.*?[_\\s]Arve number[\\s_:.]*(^TÄNAME))(?<arvenumber>[^\\s_]+).*?', 'g')
const str = `20309 NARVA
Arve number:_21954901
Arve number. Täname.
Kliendi number:_11654
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}