import Foundation
let pattern = #"(?si)(.*?[_\s]Arve number[\s_:.]*(^TÄNAME))(?<arvenumber>[^\s_]+).*?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
20309 NARVA
Arve number:_21954901
Arve number. Täname.
Kliendi number:_11654
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)