// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?si)(.*?[_\s]Arve number[\s_:.]*(^TÄNAME))(?<arvenumber>[^\s_]+).*?").unwrap();
let string = "20309 NARVA
Arve number:_21954901
Arve number. Täname.
Kliendi number:_11654
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}