#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:{{(?=[^{}]*(?:{(?!{)|}(?:!}))*}})|\G(?!^))(?:\(?\K[A-Za-z_]\w*)"
Local $sString = "Test Test2'{{TimeStamps(Descending(1))(7:8)}}/{{TimeStamps(Descending(1))(1:4)}} - '" & @CRLF & _
"" & @CRLF & _
"'{{ListHeight + 4}}, {{(ListWidth / 2) + 0.5}}, cc 6, '"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")