import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\{\\{(?=[^\\{\\}]*(?:\\{(?!\\{)|\\}(?:!\\}))*\\}\\})|\\G(?!^))(?:\\(?\\K[A-Za-z_]\\w*)";
final String string = "Test Test2'{{TimeStamps(Descending(1))(7:8)}}/{{TimeStamps(Descending(1))(1:4)}} - '\n\n"
+ "'{{ListHeight + 4}}, {{(ListWidth / 2) + 0.5}}, cc 6, '";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}