use strict;
my $str = 'Test Test2\'{{TimeStamps(Descending(1))(7:8)}}/{{TimeStamps(Descending(1))(1:4)}} - \'
\'{{ListHeight + 4}}, {{(ListWidth / 2) + 0.5}}, cc 6, \'';
my $regex = qr/(?:{{(?=[^{}]*(?:{(?!{)|}(?:!}))*}})|\G(?!^))(?:\(?\K[A-Za-z_]\w*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}