re = /(?:{{(?=[^{}]*(?:{(?!{)|}(?:!}))*}})|\G(?!^))(?:\(?\K[A-Za-z_]\w*)/m
str = 'Test Test2\'{{TimeStamps(Descending(1))(7:8)}}/{{TimeStamps(Descending(1))(1:4)}} - \'
\'{{ListHeight + 4}}, {{(ListWidth / 2) + 0.5}}, cc 6, \''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end