#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Initiated logon request((?!Received logon)[\s\S])*Received logon"
Local $sString = "<20170503-18:19:09, FIXT.1.1:BANZAI->EXEC, event> (Initiated logon request)" & @CRLF & _
" <20170503-18:19:09, FIX.4.4:BANZAI->EXEC, incoming> (8=FIX.4.4☺9=67☺35=A☺" & @CRLF & _
" 34=177☺49=EXEC☺52=20170503-18:19:09.298☺56=BANZAI☺98=0☺108=30☺10=092☺)" & @CRLF & _
" <20170503-18:19:09, FIX.4.4:BANZAI->EXEC, event> " & @CRLF & _
" (Received logon) fdsfhffghgfhgjgf 177☺49=EXEC☺52=20170503-18:19:09.298☺" & @CRLF & _
" 56=BANZAI☺98 (Received logon) more stuff after this...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")