import re
regex = re.compile(r"Initiated logon request((?!Received logon)[\s\S])*Received logon", flags=re.MULTILINE)
test_str = ("<20170503-18:19:09, FIXT.1.1:BANZAI->EXEC, event> (Initiated logon request)\n"
" <20170503-18:19:09, FIX.4.4:BANZAI->EXEC, incoming> (8=FIX.4.4☺9=67☺35=A☺\n"
" 34=177☺49=EXEC☺52=20170503-18:19:09.298☺56=BANZAI☺98=0☺108=30☺10=092☺)\n"
" <20170503-18:19:09, FIX.4.4:BANZAI->EXEC, event> \n"
" (Received logon) fdsfhffghgfhgjgf 177☺49=EXEC☺52=20170503-18:19:09.298☺\n"
" 56=BANZAI☺98 (Received logon) more stuff after this....")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")