const regex = /Initiated logon request((?!Received logon)[\s\S])*Received logon/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Initiated logon request((?!Received logon)[\\s\\S])*Received logon', 'mg')
const str = `<20170503-18:19:09, FIXT.1.1:BANZAI->EXEC, event> (Initiated logon request)
<20170503-18:19:09, FIX.4.4:BANZAI->EXEC, incoming> (8=FIX.4.4☺9=67☺35=A☺
34=177☺49=EXEC☺52=20170503-18:19:09.298☺56=BANZAI☺98=0☺108=30☺10=092☺)
<20170503-18:19:09, FIX.4.4:BANZAI->EXEC, event>
(Received logon) fdsfhffghgfhgjgf 177☺49=EXEC☺52=20170503-18:19:09.298☺
56=BANZAI☺98 (Received logon) more stuff after this....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}