#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)\$\d{1,3}(?:,\d{3})*(?:\.\d+)?(?!\S)"
Local $sString = "$123" & @CRLF & _
"$123.456" & @CRLF & _
"$123,456" & @CRLF & _
"$123,456.789" & @CRLF & _
"$12,000,000" & @CRLF & _
"aaaa$42,000,00" & @CRLF & _
"$42,000,000aaa" & @CRLF & _
"aaa$42,000,000aaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")