import re
regex = re.compile(r"(?<!\S)\$\d{1,3}(?:,\d{3})*(?:\.\d+)?(?!\S)", flags=re.MULTILINE)
test_str = ("$123\n"
"$123.456\n"
"$123,456\n"
"$123,456.789\n"
"$12,000,000\n"
"aaaa$42,000,00\n"
"$42,000,000aaa\n"
"aaa$42,000,000aaaa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")