import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)\\$\\d{1,3}(?:,\\d{3})*(?:\\.\\d+)?(?!\\S)";
final String string = "$123\n"
+ "$123.456\n"
+ "$123,456\n"
+ "$123,456.789\n"
+ "$12,000,000\n"
+ "aaaa$42,000,00\n"
+ "$42,000,000aaa\n"
+ "aaa$42,000,000aaaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}