using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$\d{1,3}(?:(?:\.|\,)\d{3})*$";
string input = @"$123
$123.456
$123,456
$123,456.789
$12,000,000
aaaa$42,000,00
$42,000,000aaa
aaa$42,000,000aaaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}