re = /^\$\d{1,3}(?:(?:\.|\,)\d{3})*$/m
str = '$123
$123.456
$123,456
$123,456.789
$12,000,000
aaaa$42,000,00
$42,000,000aaa
aaa$42,000,000aaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end