const regex = /^\$\d{1,3}(?:(?:\.|\,)\d{3})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$\\d{1,3}(?:(?:\\.|\\,)\\d{3})*$', 'gm')
const str = `\$123
\$123.456
\$123,456
\$123,456.789
\$12,000,000
aaaa\$42,000,00
\$42,000,000aaa
aaa\$42,000,000aaaa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}