using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\”name\”";
string input = @"{\""name\"":\""\"",\""\"":,\""severity\"":\""info\"",\""time\"":,\""host\"":\""\"",\""hostname\"":\""\"",\""\"":\""\"",\""\"":\""UNKNOWN CORRELATION\"",\""userId\"":\""UNKNOWN USER\"",\""moduleName\"":\""\"",\""\"":\""a\"",\""client\"":\""AgentDesktop\"",\""type\"":\""application\"",\""msg\"":\""\"",\""\"":\""\""}{\""name\"":\""\"",\""level\"":30,\""\"":\""info\"",\""time\"":,\""host\"":\""\"",\""hostname\"":\""\"",\""\"":\""\"",\""clientCorrelationId\"":\""\"",\""userId\"":\""UNKNOWN ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}