// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){\”name\”").unwrap();
let string = "{\\\"name\\\":\\\"\\\",\\\"\\\":,\\\"severity\\\":\\\"info\\\",\\\"time\\\":,\\\"host\\\":\\\"\\\",\\\"hostname\\\":\\\"\\\",\\\"\\\":\\\"\\\",\\\"\\\":\\\"UNKNOWN CORRELATION\\\",\\\"userId\\\":\\\"UNKNOWN USER\\\",\\\"moduleName\\\":\\\"\\\",\\\"\\\":\\\"a\\\",\\\"client\\\":\\\"AgentDesktop\\\",\\\"type\\\":\\\"application\\\",\\\"msg\\\":\\\"\\\",\\\"\\\":\\\"\\\"}{\\\"name\\\":\\\"\\\",\\\"level\\\":30,\\\"\\\":\\\"info\\\",\\\"time\\\":,\\\"host\\\":\\\"\\\",\\\"hostname\\\":\\\"\\\",\\\"\\\":\\\"\\\",\\\"clientCorrelationId\\\":\\\"\\\",\\\"userId\\\":\\\"UNKNOWN ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}