import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\”name\\”";
final String string = "{\\\"name\\\":\\\"\\\",\\\"\\\":,\\\"severity\\\":\\\"info\\\",\\\"time\\\":,\\\"host\\\":\\\"\\\",\\\"hostname\\\":\\\"\\\",\\\"\\\":\\\"\\\",\\\"\\\":\\\"UNKNOWN CORRELATION\\\",\\\"userId\\\":\\\"UNKNOWN USER\\\",\\\"moduleName\\\":\\\"\\\",\\\"\\\":\\\"a\\\",\\\"client\\\":\\\"AgentDesktop\\\",\\\"type\\\":\\\"application\\\",\\\"msg\\\":\\\"\\\",\\\"\\\":\\\"\\\"}{\\\"name\\\":\\\"\\\",\\\"level\\\":30,\\\"\\\":\\\"info\\\",\\\"time\\\":,\\\"host\\\":\\\"\\\",\\\"hostname\\\":\\\"\\\",\\\"\\\":\\\"\\\",\\\"clientCorrelationId\\\":\\\"\\\",\\\"userId\\\":\\\"UNKNOWN ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}