import re
regex = re.compile(r"{\”name\”", flags=re.MULTILINE)
test_str = "{\\\"name\\\":\\\"\\\",\\\"\\\":,\\\"severity\\\":\\\"info\\\",\\\"time\\\":,\\\"host\\\":\\\"\\\",\\\"hostname\\\":\\\"\\\",\\\"\\\":\\\"\\\",\\\"\\\":\\\"UNKNOWN CORRELATION\\\",\\\"userId\\\":\\\"UNKNOWN USER\\\",\\\"moduleName\\\":\\\"\\\",\\\"\\\":\\\"a\\\",\\\"client\\\":\\\"AgentDesktop\\\",\\\"type\\\":\\\"application\\\",\\\"msg\\\":\\\"\\\",\\\"\\\":\\\"\\\"}{\\\"name\\\":\\\"\\\",\\\"level\\\":30,\\\"\\\":\\\"info\\\",\\\"time\\\":,\\\"host\\\":\\\"\\\",\\\"hostname\\\":\\\"\\\",\\\"\\\":\\\"\\\",\\\"clientCorrelationId\\\":\\\"\\\",\\\"userId\\\":\\\"UNKNOWN "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")