#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(flight)?\s*(\w{2})\s*(\d{1,4})"
Local $sString = "Looking for flight BA 123 today" & @CRLF & _
"info for todays flight BA12" & @CRLF & _
"search flight ba 1234 please" & @CRLF & _
"ba 199" & @CRLF & _
"look for flightba576" & @CRLF & _
"request yesterday flightba 1456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")