const regex = /(flight)?\s*(\w{2})\s*(\d{1,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(flight)?\\s*(\\w{2})\\s*(\\d{1,4})', 'gm')
const str = `Looking for flight BA 123 today
info for todays flight BA12
search flight ba 1234 please
ba 199
look for flightba576
request yesterday flightba 1456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}