re = /(flight)?\s*(\w{2})\s*(\d{1,4})/m
str = 'Looking for flight BA 123 today
info for todays flight BA12
search flight ba 1234 please
ba 199
look for flightba576
request yesterday flightba 1456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end