using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(flight)?\s*(\w{2})\s*(\d{1,4})";
string input = @"Looking for flight BA 123 today
info for todays flight BA12
search flight ba 1234 please
ba 199
look for flightba576
request yesterday flightba 1456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}