using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!https:\/\/steamcommunity\.com$)(^(https?:\/\/)(st[\w]+)co((m|n){1,})([\w]+)\.(.*){1,}\.?(.*){1,})";
string input = @"https://steamcommunity.com
http://steanconnumity.ru
http://google.com
https://stemcomnunity.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}