import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!https:\\/\\/steamcommunity\\.com$)(^(https?:\\/\\/)(st[\\w]+)co((m|n){1,})([\\w]+)\\.(.*){1,}\\.?(.*){1,})";
final String string = "https://steamcommunity.com\n"
+ "http://steanconnumity.ru\n"
+ "http://google.com\n"
+ "https://stemcomnunity.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}