re = /^(?!https:\/\/steamcommunity\.com$)(^(https?:\/\/)(st[\w]+)co((m|n){1,})([\w]+)\.(.*){1,}\.?(.*){1,})/m
str = 'https://steamcommunity.com
http://steanconnumity.ru
http://google.com
https://stemcomnunity.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end