using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Name ((?:[A-Z]\w+[ -]?)+)";
string input = @"Name William Bob Francis Ford Coppola-Mr-Cool King-Of-The-Mountain is a fake name.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}