re = /Name ((?:[A-Z]\w+[ -]?)+)/m
str = 'Name William Bob Francis Ford Coppola-Mr-Cool King-Of-The-Mountain is a fake name.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end