$re = '/Name ((?:[A-Z]\w+[ -]?)+)/m';
$str = 'Name William Bob Francis Ford Coppola-Mr-Cool King-Of-The-Mountain is a fake name.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);