package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Name ((?:[A-Z]\w+[ -]?)+)`)
var str = `Name William Bob Francis Ford Coppola-Mr-Cool King-Of-The-Mountain is a fake name.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}