#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:src|href)=.[^'"]*\s[^'"]*['"]"
Local $sString = "<iframe src="http://some.url " width="600px" ></iframe>" & @CRLF & _
"<iframe href='http://some.url' width="600px" ></iframe>" & @CRLF & _
"<iframe src="http ://some.url" width="600px" ></iframe>" & @CRLF & _
"<iframe src='http ://some.url' width="600px" ></iframe>" & @CRLF & _
"<iframe src='http" & @CRLF & _
"://some.url' width="600px" ></iframe>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")