// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:src|href)=.[^'"]*\s[^'"]*['"]"#).unwrap();
let string = "<iframe src=\"http://some.url \" width=\"600px\" ></iframe>
<iframe href='http://some.url' width=\"600px\" ></iframe>
<iframe src=\"http ://some.url\" width=\"600px\" ></iframe>
<iframe src='http ://some.url' width=\"600px\" ></iframe>
<iframe src='http
://some.url' width=\"600px\" ></iframe>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}