$re = '/(?:src|href)=.[^\'"]*\s[^\'"]*[\'"]/';
$str = '<iframe src="http://some.url " width="600px" ></iframe>
<iframe href=\'http://some.url\' width="600px" ></iframe>
<iframe src="http ://some.url" width="600px" ></iframe>
<iframe src=\'http ://some.url\' width="600px" ></iframe>
<iframe src=\'http
://some.url\' width="600px" ></iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);