re = /(?:src|href)=.[^'"]*\s[^'"]*['"]/
str = '<iframe src="http://some.url " width="600px" ></iframe>
<iframe href=\'http://some.url\' width="600px" ></iframe>
<iframe src="http ://some.url" width="600px" ></iframe>
<iframe src=\'http ://some.url\' width="600px" ></iframe>
<iframe src=\'http
://some.url\' width="600px" ></iframe>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end