using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(RSUINTREL-[0-9]+\s+|PANGUSW-[0-9]+\s+|APRICOT-[0-9]+\s+|GEN6PANGU-[0-9]+\s+|SWFCN-[0-9]+\s+)+.*$";
string input = @"### Should Pass Test
SWFCN-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287 APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
APRICOT-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287 debug 222 test test test !!!!
GEN6PANGU-1111 Add gitlab ci
RSUINTREL-957 add test message
### Failed to match test
SWFCN-2a7 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}