import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(RSUINTREL-[0-9]+\\s+|PANGUSW-[0-9]+\\s+|APRICOT-[0-9]+\\s+|GEN6PANGU-[0-9]+\\s+|SWFCN-[0-9]+\\s+)+.*$";
final String string = "### Should Pass Test\n\n"
+ "SWFCN-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME\n"
+ "SWFCN-287 APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME\n"
+ "APRICOT-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME\n"
+ "SWFCN-287 debug 222 test test test !!!!\n"
+ "GEN6PANGU-1111 Add gitlab ci\n"
+ "RSUINTREL-957 add test message\n\n"
+ "### Failed to match test\n\n"
+ "SWFCN-2a7 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME\n"
+ "SWFCN-287APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME\n"
+ "debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}