re = /^(RSUINTREL-[0-9]+\s+|PANGUSW-[0-9]+\s+|APRICOT-[0-9]+\s+|GEN6PANGU-[0-9]+\s+|SWFCN-[0-9]+\s+)+.*$/m
str = '### Should Pass Test
SWFCN-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287 APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
APRICOT-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287 debug 222 test test test !!!!
GEN6PANGU-1111 Add gitlab ci
RSUINTREL-957 add test message
### Failed to match test
SWFCN-2a7 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end