import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:href|alt|title)\\s*=\\s*\"[^\"]*)(Kathryn Kuhlman|Max KANTCHEDE)";
final String string = "Meet God\\'s General Kathryn Kuhlman. <br>\n"
+ "<img class=\"lazy_responsive\" title=\"Kathryn Kuhlman - iUseFaith.com\" src=\"https://www.iusefaith.com/ojm_thumbnail/1000/32f808f79011a7c0bd1ffefc1365c856.jpg\" alt=\"Kathryn Kuhlman - iUseFaith.com\" width=\"1600\" height=\"517\" />\n"
+ "<br>\n"
+ "Follow <a href=\"https://www.iusefaith.com/en-354\" title=\"Kathryn Kuhlman\">Kathryn Kuhlman</a>\n"
+ "<br>\n"
+ "Max KANTCHEDE\n"
+ "<a href = \"blah blah blah Kathryn Kuhlman\"/>Kathryn Kuhlman</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}