const regex = /((?:href|alt|title)\s*=\s*"[^"]*)(Kathryn Kuhlman|Max KANTCHEDE)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:href|alt|title)\\s*=\\s*"[^"]*)(Kathryn Kuhlman|Max KANTCHEDE)', 'gm')
const str = `Meet God\\'s General Kathryn Kuhlman. <br>
<img class="lazy_responsive" title="Kathryn Kuhlman - iUseFaith.com" src="https://www.iusefaith.com/ojm_thumbnail/1000/32f808f79011a7c0bd1ffefc1365c856.jpg" alt="Kathryn Kuhlman - iUseFaith.com" width="1600" height="517" />
<br>
Follow <a href="https://www.iusefaith.com/en-354" title="Kathryn Kuhlman">Kathryn Kuhlman</a>
<br>
Max KANTCHEDE
<a href = "blah blah blah Kathryn Kuhlman"/>Kathryn Kuhlman</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}