// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)((?:href|alt|title)\s*=\s*"[^"]*)(Kathryn Kuhlman|Max KANTCHEDE)"#).unwrap();
let string = "Meet God\\'s General Kathryn Kuhlman. <br>
<img class=\"lazy_responsive\" title=\"Kathryn Kuhlman - iUseFaith.com\" src=\"https://www.iusefaith.com/ojm_thumbnail/1000/32f808f79011a7c0bd1ffefc1365c856.jpg\" alt=\"Kathryn Kuhlman - iUseFaith.com\" width=\"1600\" height=\"517\" />
<br>
Follow <a href=\"https://www.iusefaith.com/en-354\" title=\"Kathryn Kuhlman\">Kathryn Kuhlman</a>
<br>
Max KANTCHEDE
<a href = \"blah blah blah Kathryn Kuhlman\"/>Kathryn Kuhlman</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}