#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^.+\bCurrent: ([\d.]+).+\bLatest: ([\d.]+).*$"
Local $sString = "GAMADV-XTD3 6.07.31 - https://github.com/taers232c/GAMADV-XTD3 - pyinstaller" & @CRLF & _
"Ross Scroggs <ross.scroggs@gmail.com>" & @CRLF & _
"Python 3.9.7 64-bit final" & @CRLF & _
"Windows 10 10.0.18363 SP0 Multiprocessor Free AMD64" & @CRLF & _
"Path: C:\GAMADV-XTD3" & @CRLF & _
"Config File: C:\GAMConfig\gam.cfg, Section: DEFAULT, customer_id: C047encoi, domain: sonos.com " & @CRLF & _
"Version Check:" & @CRLF & _
" Current: 6.07.31" & @CRLF & _
" Latest: 6.07.31" & @CRLF & _
""
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)