re = /(?s)^.+\bCurrent: ([\d.]+).+\bLatest: ([\d.]+).*$/
str = 'GAMADV-XTD3 6.07.31 - https://github.com/taers232c/GAMADV-XTD3 - pyinstaller
Ross Scroggs <ross.scroggs@gmail.com>
Python 3.9.7 64-bit final
Windows 10 10.0.18363 SP0 Multiprocessor Free AMD64
Path: C:\\GAMADV-XTD3
Config File: C:\\GAMConfig\\gam.cfg, Section: DEFAULT, customer_id: C047encoi, domain: sonos.com
Version Check:
Current: 6.07.31
Latest: 6.07.31
'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result